Monday, August 18, 2008

Lotus Quickr HF19 and read the instructions, for help

Like many of us we appreciate it when our administrative life is made easier by the vendor. Lotus has put out a recent update to Quickr and it has an automated installer. Excellent, right?
Well, let's just say my server failed 2 of the 3 prerequisites.

Currently the Lotus Quickr hotfix installer will only run on Win32 based systems, for other systems, please refer to IBM’s Fix Central website.

Prerequisites:
Win32 based system, Check!
Java 1.5 or above must be installed on the Domino Quickr server. Thought it was updtaed, oops!
The Domino program directory (eg: c:\Program Files\IBM\Domino) must be in the System PATH variable. One would think this is done by defualt these days when you install Domino, evidently this is not the case. OOPS!

So, got the file, try to run it and nothing.

EDITED 8/20/2008: I resolved this error below. It was in the qpconfig.xml file. I had messed up some syntax. DOH!

PS forgot to ask, if anyone knows what this is referring to:
08/17/2008 08:47:22 PM Start IConfig::ReadLtpaConfig( )
08/17/2008 08:47:22 PM End IConfig::ReadLtpaConfig( )
08/17/2008 08:47:26 PM JVM: Java Virtual Machine initialized.
08/17/2008 08:47:26 PM Agent error: [Fatal Error] :1495:2: The markup in the document preceding the root element must be well-formed.
08/17/2008 08:47:26 PM org.xml.sax.SAXParseException: The markup in the document preceding the root element must be well-formed.
08/17/2008 08:47:28 PM Event Monitor started

This is the startup on the server after I changed the OS name to match the DNS name.
went from fred1 to efred the rest stayed the same.
A Quickr qptool update maybe is needed?
Read file, maybe path is wrong, edited path looks ok.
Java isn't up to date. Normally one of the first things I do when building a server is get all the updates on OS, Java, Domino, addons, etc. Guess this one slipped through.

Now to go finish the conector updates too.